"rails generate" from Hartl Rails Tutorial Ch 3 just hanging up in terminal

rails

#1

I’m working through Hartl’s Rails Tutorial. Last night I made my way through Chapter 3 successfully. This morning I deleted the sample_app in Cloud9, Bitbucket and Heroku and started Chapter 3 over again to reinforce my learning.

Today, when I got to the “rails generate” statement from Listing 3.4, the terminal just hung up. I had to close the Terminal window to get out of it. When I reopened a terminal window, git status showed that no files had been changed so the generate statement did nothing at all.

When I enter “rails --version”, the version is 4.2.2 as expected.

I’ve deleted everyting and closed everything and shut my computer down and restarted all over again with the same result.

Since it worked last night, it leads me to believe there is something going on with Cloud9’s Rails today. I’ll try again tonight, but in the meantime, anyone have any ideas?

Thanks in advance.


#2

I’m having a similar problem. Looks like March 30th/April 1st may have been when the problem started.