Python autocomplete


#1

I’m using c++ workspace, and it works fine,
at the same time, I need to write a few python scripts for a project.
I’ve removed python 2.7 to avoid any conflicts and currently there is Python 3.4 .

currently project config section releated with python looks like:
“python”: {
"@completion": true,
"@path": “/usr/local/lib/python2.7/dist-packages:/usr/local/lib/python3.4/dist-packages:/usr/local/lib/python3.5/dist-packages”,
"@version": “python3”
},

you see this is the same like in default python workspace.
however autocomplete doesn’t work properly,
(running and linting work)
just a tips with a symbols from current file,
nothing from “imports”

could you explain pls how to config python env from scratch?


#2

any chance to get a step-by-step python’s setting up?
I mean not a something like here
but full manual with a setting up the python itself.
because currently I’ve installed python3 and autocomplete is not working

thank you!


#3

I have the same issue. Autocomplete works only if I select Python Version 2.