Pushing postgres db to heroku: asks for ubuntu password!

heroku
workspace
postgresql

#1

Hi all,

I’m hoping you guys can help me out with this.

I have a postgres db called mydb setup in a cloud9 local workspace. It works correctly in the workspace and I have successfully linked it to a heroku remote. All that is left is to push it to my heroku app.

So, I run the following command in the terminal

$ heroku pg:push mydb DATABASE_URL --app [HEROKU_APP_NAME]

And I get the following prompt

heroku-cli: Pushing mydb ---> postgresql-horizontal-52912
Password:

It didn’t let me proceed without a password so I setup a ubuntu user password for my workspace and a password for postgres. I tried both as the Password above with no success:

pg_dump: [archiver (db)] connection to database "mydb" failed: FATAL:  password authentication failed for user "ubuntu"
FATAL:  password authentication failed for user "ubuntu"
pg_restore: [archiver] input file is too short (read 0, expected 5)

My db is working correctly in the workspace with no access issues. Which password do you think is being asked for user ubuntu (if not the workspace or the postgres password) when I try to push it to a heroku remote? Can it be bypassed?

Thanks!