Public SSH key needed


#1

Absolute newby. Joined Cloud9 and followed instructions (free plan). Went to setup workspace and tried to use ‘clone’ option but kept getting errors requiring a public SSH key (message didn’t have any link) so I cancelled membership and tried again with same result.
Any help would be appreciated. TIA.
BJA


#2

Hi,

Thank you for writing in. Can you send us a screenshot of the filled out form (with any fields you’d like to remain private blurred out / redacted) along with the error message so we can help?

Thanks!

Regards,
​Mutahhir


#3

It sounds like you might be trying to clone a private workspace from a Github or Bitbucket account with an SSH link but you haven’t setup your SSH key with Github/Bitbucket yet.

If this is the case, you’ll want to take your Cloud9 SSH key and add it to Github and then you’ll be good.


Cloning workspace from github including installations
#4

Hi Brady,
Thanks for the reply.
That’s how I started (cloning) but I couldn’t see where to get the SSH key from.
Since then, I have deleted the workspace and added the rails-tutorial workspace but I cannot open it once created. It just hangs looking for c9.io.

I’ll get there I guess but it hurts my brain at the moment. :slight_smile:

Cheers,
Bruce


#5

Looks like it just took a little while to load the workspace but it’s up now :point_up:


#6

Hi Brady,

The workspace is up but I cannot open it. I hit the Open button, the tab at the top shows “Waiting for ide.c9.io” then after a couple of minutes an error page displays stating :“This page can’t be displayed” and showing three reasons why this could be.

I have two workspaces now, the cloned one and the rails-tutorial one but I get the same result when I try to open either of them (but it’s the rails-tutorial one I am really after).

Sorta stops me in my tracks right now.

Cheers,
Bruce