Project not starting


#1

I simply can’t run my project.
When I click Run project it simply does nothing but convert the button to Stop

If the apache tab doesn’t exist, it’s created, but nothing gets executed.

I tried to restart my workspace, didn’t work.


#2

Can you post a screenshot of the Apache tab? Are there any errors there? Are you able to run Apache from the command line by itself, maybe by running sudo service apache start.


#3

I was able to run apache just by executing apache in the terminal.

However, when I run mysqld, I get this:

microdroid:~/workspace $ mysqld
2016-05-10 19:07:27 0 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
2016-05-10 19:07:27 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-05-10 19:07:27 0 [Note] mysqld (mysqld 5.6.30-0ubuntu0.14.04.1) starting as process 2043 ...
2016-05-10 19:07:27 2043 [Warning] Can't create test file /var/lib/mysql/microdroid-codebottle-2489349.lower-test
2016-05-10 19:07:27 2043 [Warning] Can't create test file /var/lib/mysql/microdroid-codebottle-2489349.lower-test
mysqld: Can't change dir to '/var/lib/mysql/' (Errcode: 13 - Permission denied)
2016-05-10 19:07:27 2043 [ERROR] Aborting

2016-05-10 19:07:27 2043 [Note] Binlog end
2016-05-10 19:07:27 2043 [Note] mysqld: Shutdown complete

Oh and, I just tried to Stop the project, the button is now stuck, it’s unclickable anymore
There’s no output in the Apache/PHP window


#4

I am not sure if staffs fixed my workspace or something, but it just ran the project one more time (I ran it several times before) and it ran fine.