Problem with mongodb


#1

hello there i have this problem with mongodb it stopped working and i tried every thing the – repair it didn’t work i tried removing mongod.lock and run ./mongod it didn’t give me an error but it doesn’t connect it stop at this

2018-08-06T13:52:15.492+0000 ** WARNING: --rest is specified without --httpinterface,
2018-08-06T13:52:15.492+0000 ** enabling http interface
warning: bind_ip of 0.0.0.0 is unnecessary; listens on all ips by default
2018-08-06T13:52:15.495+0000 [initandlisten] MongoDB starting : pid=4516 port=27017 dbpath=data 64-bit host=mostafagamal123-webdevbootcamp-6276555
2018-08-06T13:52:15.496+0000 [initandlisten] db version v2.6.12
2018-08-06T13:52:15.496+0000 [initandlisten] git version: d73c92b1c85703828b55c2916a5dd4ad46535f6a
2018-08-06T13:52:15.496+0000 [initandlisten] build info: Linux build5.ny.cbi.10gen.cc 2.6.32-431.3.1.el6.x86_64 #1 SMP Fri Jan 3 21:39:27 UTC 2014 x86_64 BOOST_LIB_VERSION=1_49
2018-08-06T13:52:15.496+0000 [initandlisten] allocator: tcmalloc
2018-08-06T13:52:15.496+0000 [initandlisten] options: { net: { bindIp: “0.0.0.0”, http: { RESTInterfaceEnabled: true, enabled: true } }, storage: { dbPath: “data”, journal: { enabled: false } } }
2018-08-06T13:52:15.506+0000 [initandlisten] waiting for connections on port 27017
2018-08-06T13:52:15.506+0000 [websvr] admin web console waiting for connections on port 28017
2018-08-06T13:54:48.825+0000 [clientcursormon] mem (MB) res:91 virt:399
2018-08-06T13:54:48.825+0000 [clientcursormon] mapped:240
2018-08-06T13:54:48.825+0000 [clientcursormon] connections:0

then nothing happens and all my previous databases does’t work
now i started an new workspace and installed every thing again thinking that this will help solve the problem but this is the result

mongod --help for help and startup options
2018-08-07T07:28:45.950+0000 [initandlisten] MongoDB starting : pid=2158 port=27017 dbpath=/data/db 64-bit host=mostafagamal123-blog-app-6299865
2018-08-07T07:28:45.950+0000 [initandlisten] db version v2.6.12
2018-08-07T07:28:45.950+0000 [initandlisten] git version: d73c92b1c85703828b55c2916a5dd4ad46535f6a
2018-08-07T07:28:45.951+0000 [initandlisten] build info: Linux build5.ny.cbi.10gen.cc 2.6.32-431.3.1.el6.x86_64 #1 SMP Fri Jan 3 21:39:27 UTC 2014 x86_64 BOOST_LIB_VERSION=1_49
2018-08-07T07:28:45.951+0000 [initandlisten] allocator: tcmalloc
2018-08-07T07:28:45.951+0000 [initandlisten] options: {}
2018-08-07T07:28:45.960+0000 [initandlisten] journal dir=/data/db/journal
2018-08-07T07:28:45.960+0000 [initandlisten] recover begin
2018-08-07T07:28:45.960+0000 [initandlisten] info no lsn file in journal/ directory
2018-08-07T07:28:45.960+0000 [initandlisten] recover lsn: 0
2018-08-07T07:28:45.960+0000 [initandlisten] recover /data/db/journal/j._0
2018-08-07T07:28:45.961+0000 [initandlisten] recover applying initial journal section with sequence number 90
2018-08-07T07:28:45.976+0000 [initandlisten] recover cleaning up
2018-08-07T07:28:45.976+0000 [initandlisten] removeJournalFiles
2018-08-07T07:28:45.981+0000 [initandlisten] recover done
2018-08-07T07:28:45.981+0000 [initandlisten] preallocating a journal file /data/db/journal/prealloc.0
2018-08-07T07:28:48.027+0000 [initandlisten] File Preallocator Progress: 754974720/1073741824 70%
2018-08-07T07:28:50.583+0000 [initandlisten] waiting for connections on port 27017
2018-08-07T07:29:50.581+0000 [clientcursormon] mem (MB) res:44 virt:344
2018-08-07T07:29:50.581+0000 [clientcursormon] mapped (incl journal view):160
2018-08-07T07:29:50.581+0000 [clientcursormon] connections:0

and when i tried to run the app it gives me errors in the documentations of mongo and mongoose like some properties are undefined