Problem installing OpenLiteSpeed


#1

I’m just using c9 for 2 days and having a problem when trying to install openlitespeed web service replace for apache.

I chose blank template.
I’ve purged all apache2, php5, mysql; autoremove and also deleted apache, php config folder.
I’ve checked that there’s no more processes using ports.
I’ve tried installing openlitespeed using 1-click installer bash from guide on the openlitespeed homepage (because the os is ubuntu14)
After that, I change the default listener port to 8081 and the admin port to 8082 and disable its secure required by changing secure key to 0 in admin config file (it’s loop error before when i tried to port 8080 and left the secure key as default).

That’s all and now I can access the welcome page of openlitespeed, but I can’t access the phpinfo (sometimes it shows up but when fail again with f5 refresh) It shows this error: HPE_UNEXPECTED_CONTENT_LENGTH: Request could not be proxied!,
and the error logs: [modcompress—] compressbuf in 0, return -1 (written 0, flag in 1)
The admin page have the same problem (there’s no error logs when I access the admin page), i think that is the problem with php but i’ve no idea to fix this.

Someone help me?