Preview is not working


#1

I installed the latest Cloud9 SDK in Debian and Preview is not working. Apache is running and appears in the list of services.
I created a simple HTML page as shown below and the error returned is:
{“Error”: {“code”: 500, “scope”: “standalone”, “message”: “connect ECONNREFUSED”}}

HTML test:
< html>
< body>
TEST
< /body>
< /html>

To run the Node I do:
Node /root/c9sdk/server.js -l 192.168.137.2 -p 3000 -a: &

Does anyone know how to fix PREVIEW problem?


#2

hey w88, the preview system on C9 appears to be wired to host 0.0.0.0:8080
try that.


#3

No. After the Cloud9 SDK is installed, the default configuration IP is 0.0.0.0 and the port is 8080. If you try to open Cloud9 in the browser using http: // localhost: 8080 on the same device Cloud9 is installed on, it’ll work. But if you wanna open Cloud9 from another device, you’ll need to set a valid IP on your network, such as 192.168.137.2 as in my case. My device is a Beaglebone with Linux Debian, where I installed the Cloud9 SDK. My device where I’ve got access to Cloud9 is a notebook with Windows10.

In the native installation of Cloud9 for the Beaglebone (from the lastest Linux Debian image for the Beaglebone), Cloud9 and Preview work fine, but the autocomplete code doesn’t work. Due to this autocomplete code problem, I opted to install the Cloud9 SDK and then I found another problem, this time with Cloud9 Preview.

I think the problem is just a simple path setting. I have not found it yet.


#4

Okay, you’re in a completely different hemisphere than I. :wink: