PHP.ini non-responsive to max filesize increase

php
wordpress

#1

Hi,

I followed this thread to find the php.ini file in the root directory of my C9 Wordpress install: The uploaded file exceeds the upload_max_filesize directive in php.ini

I saved the new file limit of 20 mb and attempted to reupload a 2.7mb file: http://i.imgur.com/6p9qzYS.png

I continue to get the error: The uploaded file exceeds the upload_max_filesize directive in php.ini.

Why is the new setting being ignored?

EDIT: Solved by stopping and starting the server. Can someone tell me why this fixed it? I am not used to having to perform this step with Wordpress updates on my old shared host.