PHP application will not run with debugger (anymore)


#1

All of a sudden my PHP application will not run with a debugger.
I use the standard Apache httpd runner and have run and debugged the application for some days now, but now everything stops!

When I press the run button nothing happens. There are noe messages in the output window. It seems like it tries to start (as the button changes to “stop” for a couple of sec before goes back). I have tried to restart the workspace. I checked to see if apache service is running; which it is.

help!


#2

Have you tried using PHP (Built in web server) as the runner? … To be honest, I’ve found the whole debug and run configurations to be buggy. I have to stop whatever is running, restart the workspace and then use the “run -> run with…” and then choose the “PHP built in” option.

… If you do try this, make sure you manually start any other services. For example I always forget to start MySQL!


#3

yup. I tried that as well. No luck…


#4

on which workspace do you see this error?


#5

pirvate: ssbarcodegenerator

Today it’s working better. I experienced a couple of hick-ups earlier this morning. I decided to log completely out of cloud9 and stay logged out for about 10min. Then I logged back in and it was working.

t


#6

I am experiencing the same exactly issue


#7

I can no longer run php both with apache/php and built in. Was working fine yesterday. I tried restarting server as well, but still doesn’t work.


#8

I added ?reset=1 to the url and it seemed to do the trick


#9

good suggestion. I’ll try that.
My workspace has been working good the last week. I have been diligent about shutting down/stop apache between my working session. Earlier I would start apache. Do my coding, but just leaving it when I left to do other things.

I am not sure if it has anything to do with the erroneous behaviour, but as it turns out things have been stable for me lately.

t


#10

I had the same issue back months ago, and now it seems to have come back to haunt my php dev. I will try the loggin out of the session for 10 min to see if it works, as ?reset=1 did not seem to work


#11

Did you ever get it working? Mine doesn’t seem to be :frowning:


#12

Its a bug in the ide that has been going on for months. the debugger gets error connecting and then i need to restart and nothing works. It seems like the issue is alleatory as it seems it does not get solved and has happened to me with javascript aswell. I wonder if the issue happens with paid accoutns too, as mine is free. I was thinking of getting a paid account but with these kind of bugs i am not sure if i will go for it.


#13

Hello I have same issue again. I did not touch anything, and today the app does not launch with debugger on. I need to turn on php debugger off in order for app to work.

Any news on this?

Thanks!


#14

Hello,

Just to say that quitting c9 then relogging in solved the problem!

cheers!
ram