On Save Strip WhiteSpace malfunctioning


#1

Hey everybody!
Since a few hours, the option is also deleting the line where you are.
imagine:
This is a | line (the | is my cursors) then I press ctrl+s and the line is like this This is a
It’s really anoying!
Anybody with the same issue?


#2

Having exactly the same issue.


#3

Same here, its also started opening the browser save page dialog when Ctrl-s, I’ve tested this in chrome and FF, same issues.Also reset c9 settings default


#4

I seem to have fixed it for me, by changing the key-bindings platform property to win.

"key-bindings": {
        "@platform": "unix", <--- change to win and reload c9
        "@preset": "default",
        "json()": [
...

#5

Does it change many things? I’m using linux so…


#6

Im on linux also, im not even sure what it does. :confused:


#7

Where can I access this file? Thanks for your info


#8

Its in the user setting json file,

So click the Cloud9 bit and then in the dropdown its “Open your User Settings” then its on line 110


#9

It doesn’t work to me


#10

thanks, for reporting the issue. We are preparing a release with a fix


#11

You are welcome! But please be fast :stuck_out_tongue: :wink:


#12

I have never noticed that. Very odd. I changed my keybindings to win too but had no effect.


#13

@jms1989 this was an issue with strip whitespace on save setting.
It should is fixed now