[Object object] error when share request granted


#1

I had a friend visit my workspace URL and request access once they were registered and when approving the request, I ran into 3 problems, 2 of them closely related.

  1. My UI showed an [Object object] error dialog.
  2. The friends UI did not function properly until they did an additional full reload
  3. Our UI’s were not sync’d until I then did a full reload.

P.S. The “invite by email” feature is not really invite by email (it apparently only works if a user already has an account which is sad, since an email invite is what it implies would happen)


#2

We’re going to be adding invite by email without an account soon. I’ll investigate what happened and if you could provide the following information that’d be very helpful:

Has collaboration worked since the initial refreshes?
Did you notice any other issues at the time? (Such as being unable to open/edit files, disconnects etc)
What Browser and OS are each of you using?

if this happens again could you also please open up chrome developer tools and (Option+Cmd+I on OSX or Ctrl+Shift+I on Windows/Linux) and let us know if there are any errors in there.


#3

The initial problem for the invited user was, they could view but not edit anything.

The initial problem from my side, was there was collaboration functionality.

Both appeared to work fine once both sides had refreshed.

Both users are Chrome on OSX

And sure, if it happens again, I’ll grab additional console errors if there are any.


#4

@ktiedt we can reproduce the [Object object] bug and will be making an internal issue about it to handle it. If you see the other behavior mentioned above and have ideas on reproducing that then please post that as well.