NPM install is not working


#1

Hi, guys, I’m working through the FreeCodeCamp Node.js curriculum and am trying to install packages, but npm install is not working. I’ve tried npm install bl and npm install concat-stream, and get the same series of errors (below). Any thoughts?

baruchkogan:~/workspace $ npm install bl
npm ERR! Linux 4.2.0-c9
npm ERR! argv “/home/ubuntu/.nvm/versions/node/v4.4.5/bin/node” “/home/ubuntu/.nvm/versions/node/v4.4.5/bin/npm” “install” "bl"
npm ERR! node v4.4.5
npm ERR! npm v3.10.2
npm ERR! code ECONNREFUSED
npm ERR! errno ECONNREFUSED
npm ERR! syscall connect

npm ERR! Error: connect ECONNREFUSED 127.0.0.1:15443
npm ERR! at Object.exports._errnoException (util.js:870:11)
npm ERR! at exports._exceptionWithHostPort (util.js:893:20)
npm ERR! at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1061:14)
npm ERR! { [Error: connect ECONNREFUSED 127.0.0.1:15443]
npm ERR! code: ‘ECONNREFUSED’,
npm ERR! errno: ‘ECONNREFUSED’,
npm ERR! syscall: ‘connect’,
npm ERR! address: ‘127.0.0.1’,
npm ERR! port: 15443 }
npm ERR!
npm ERR! If you are behind a proxy, please make sure that the
npm ERR! ‘proxy’ config is set properly. See: ‘npm help config’

npm ERR! Please include the following file with any support request:
npm ERR! /home/ubuntu/workspace/npm-debug.log


#2

Solved, by using npm install --registry http://registry.npmjs.org/

Very strange.


#3

Not solved for me
Here is what I have used to far I tried
npm config set proxy null
npm config set registry http://registry.npmjs.org/