Nodejs : Breakpoint not working for an app but works for others


#1

Hi,

I’m building an app and for some reason the debugger seems to have stopped working. No matter where I insert a break point in the code I cannot get it to kick in. If I create a new .js file , insert a few lines of code and insert a break point the debugger works ok but no matter what I try I cannot get it working on the debugger working on the app i’m working on.

There are no error messages etc, the debugger happily starts the app and the app runs as expected. I have restarted my workspace, tried copying the app.js file to another filename etc etc.


#2

It appears your app is in a symlinked directory, try running it from original directory instead.


#3

Thanks, if I run the app from inside the actual directory instead of the sym linked to it directory the debugger works fine.

Many thanks :slight_smile:


#4

Hi,
I encountered the same problem, but I don’t know what does it mean by “my app is in symlinked directory”? And I also have no idea about how to run my app from original directory. Could you please tell more detailly?

My app is a simple expressJS application. Thank you so much in advance.


#5

Run these commands in the directory where your app is installed and paste the results back here

1 . pwd
2. /bin/pwd
3. cd … ; ls -l

If you don’t know what a sym linked directory is I doubt you’ll have one , ie you have to create the symbolic link for there to be one. Send me your output from those 3 commands and that should tell us if it’s the same issue.


#6

Hi neilbottomley,

Thank you for your reply. I pasted the output below. I guess it’s not the same issue, right?

celinechien:~/workspace (master) **pwd** **/home/ubuntu/workspace** celinechien:~/workspace (master) /bin/pwd
/home/ubuntu/workspace
celinechien:~/workspace (master) $ cd …; ls -l
total 8
drwxr-xr-x 3 ubuntu ubuntu 4096 Aug 31 2016 lib/
drwxr-xr-x 11 ubuntu ubuntu 4096 Mar 10 06:29 workspace/


#7

No, it’s not the same problem that I had, you are not using sym links. Have you tried a different browser? I do find that it sometimes stops working for no reason and I have to restart my browser. Maybe just try running it against some basic code in a single file too?

I would create a new support post if you are still having problems.