Node/gulp issues

nodejs

#1

I’m getting this error when trying to run ‘gulp’ on a WP Install:

/home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/source-map/lib/source-map-generator.js:277
  throw new Error('Invalid mapping: ' + JSON.stringify({
  ^

Error: Invalid mapping: {"generated":{"line":1382,"column":17},"source":"../bower_components/bootstrap-sass/assets/stylesheets/bootstrap/mixins/_clearfix.scss","original":{"line":13,"column":-13},"name":null}
at SourceMapGenerator_validateMapping [as _validateMapping] (/home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/source-map/lib/source-map-generator.js:277:13)
at SourceMapGenerator_addMapping [as addMapping] (/home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/source-map/lib/source-map-generator.js:101:12)
at /home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/concat-with-sourcemaps/index.js:60:28
at Array.forEach (native)
at SourceMapConsumer_eachMapping [as eachMapping] (/home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/source-map/lib/source-map-consumer.js:155:14)
at Concat.add (/home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/concat-with-sourcemaps/index.js:58:18)
at DestroyableTransform.bufferContents [as _transform] (/home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/gulp-concat/index.js:68:12)
at DestroyableTransform.Transform._read (/home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/readable-stream/lib/_stream_transform.js:159:10)
at DestroyableTransform.Transform._write (/home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/readable-stream/lib/_stream_transform.js:147:83)
at doWrite (/home/ubuntu/workspace/wp-content/themes/viacibo-sage/node_modules/readable-stream/lib/_stream_writable.js:347:64)

This started when I tried to update a couple different modules that were outdated. Since then, this error stops the gulp process. I’ve uninstalled and reinstalled gulp with no change to the problem.
I’m thinking I need to fully remove node and reinstall, but I just wanted to make sure of the process to do this, so that I don’t break anything else.

Any suggestions would be great!


#2

Looks to just be an issue with ‘source-map’ not working with the most updated bootstrap-sass…Doesn’t seem to like the ampersands used in bootstrap.