No options appear in Code Formating section

workspace

#1

Hello there,

When I click in the “Code Formatting” option there aren’t suboptions for make formatting.

How can I fix this?

Thanks to all.


Codeformatter in the IDE
#2

I’ve noticed this too (was posting the same question when yours came up as similar). It’s very frustrating; I used it all the time and now it seems to have just vanished.


#3

We’ve been reworking the code formatting menu and settings to support custom formatters. You can specify these formatters for languages like JavaScript and Python. For JSON, we still use JSBeautify. If you pick the “Apply Code Formatting” menu item it should still format your JSON. Is there anything else or another use case you guys have in mind that’s not covered right now?


#4

For reference, this is the original formatter menu:

Note how it only had 1 option for JSON. That is now covered by “Apply Code Formatting”


#5

@lennartcl, so how can I specify these formatters myself?
Thanks for your reply