No monospace fonts?


#1

My editor and terminals were only displaying in times new roman. In preferences, all the default monospace fonts were listed though. I reset to factory defaults and it’s still not displaying in the fonts listed.


#2

Do you have any custom styles on, either through your browser or through your stylesheet? What happens if you add ?reset=1 to the end of your IDE URL?


#3

I’m not using any custom styles, and adding ?reset=1 to the URL had no effect – still displaying times new roman font.
(which is an issue because it’s mucking up my cursor placement)


#4

what OS/browser do you use? this can be caused if monospace font is not installed on the system, or is overridden by browser extension or a setting


#5

I’m using Chrome 64.0.3282.186 (Official Build) (64-bit) (cohort: Stable) on Windows 7. In case the info helps, this just started happening the other week. I was using this rig for months with no problems. It also is not an issue if I use IE (shudder the thought!) on this Windows 7 machine or if I’m on my Macbook.


#6

Do you have any extensions installed, if yes try opening the ide in incognito tab, if that doesn’t help check the setting for fixed width font in chrome://settings/fonts?search=fonts


#7

Thanks, that solved it! “Times New Roman” was the default monospace font in Chrome’s settings for some reason. Switched it to a proper monospace font and now the IDE is displaying nicely.