No autocomplete, nor input menu


#1

Hello,

I’m working with Cloud9 on a Beaglebone Black, with the latest firmware. But autocomplete is not working, nor the input menu in project settings is not showing. Didn’t find anything on this forum or google. Anyone knows whats going on?

I’m programming in Node.js but also in Python and C++ autocomplete is not working.


BeagleBonesBlack Development using a Cloud9 workspace
#2

are there any errors in browser console? what version is shown in about dialog, whihc can be opened using Cloud9>About Cloud9 menu item.


#3

@harutyun

There are no error in the console. I run Cloud9 Version 3.1.2374 (08fc5f16f4).


#4

When I flash “Debian 8.3”, instead of the newer 8.4 autocomplete is working. Cloud9 version installed is Version 3.1.1084. I did a “apt-get dist-upgrade” and autocomplete still worked.

Installed versions in Debian 8.3 are npm 3.8.2 and node v0.10.42. Updated those to npm 3.9.5 and node v6.2.2, which is also updating Cloud9 to Version 3.1.2374 . After the update autocomplete is not working anymore.

Don’t know if the problem is with npm, node or Cloud9.


#5

Does the linting work?


#6

I made one mistake in my last reply, after the ap-get dist-upgrade cloud9 update to Version 3.1.2374 and autocomplete is not working (I didn’t refresh chrome after the update).

But still autocomplete is not working, also linting is not showing nothing. But i did get a error message: “Language worker could not be loaded”


#7

I’m using chrome browser, but also in firefox and edge I get this error.


How to add a c,c++ template to C9 SDK standalone install?
#8

Sounds like cloud9 version distributed in beaglebone is broken,
Do you not get any errors in chrome devtools even when there is "Language worker could not be loaded" error? Maybe you have some filters activated?


#9

Chrome devtools gives the following errors:

default.js:6821 Object {stack: "997: 2983: Error: Cannot find module '/opt/cloud9/…nebuild/node_modules/vfs-socket/worker.js:473:22)", code: "MODULE_NOT_FOUND", message: "Cannot find module '/opt/cloud9/build/standalonebuild/plugins/c9.cli.bridge/bridge-service.js'"}code: "MODULE_NOT_FOUND"message: "Cannot find module '/opt/cloud9/build/standalonebuild/plugins/c9.cli.bridge/bridge-service.js'"stack: "997: 2983: Error: Cannot find module '/opt/cloud9/build/standalonebuild/plugins/c9.cli.bridge/bridge-service.js'↵
    at Function.Module._resolveFilename (module.js:338:15)↵
    at Function.Module._load (module.js:280:25)↵
    at Module.require (module.js:364:17)↵
    at require (module.js:380:17)↵
    at Object.extend (/opt/cloud9/build/standalonebuild/node_modules/vfs-local/localfs.js:2379:24)↵
    at /opt/cloud9/build/standalonebuild/node_modules/vfs-local/localfs.js:236:30↵
    at b (domain.js:183:18)↵
    at Domain.run (domain.js:123:23)↵
    at Object.api.(anonymous function) [as extend] (/opt/cloud9/build/standalonebuild/node_modules/vfs-local/localfs.js:235:23)↵
    at Worker.wrapped (/opt/cloud9/build/standalonebuild/node_modules/vfs-socket/worker.js:473:22)"
__proto__: Object
__defineGetter__: __defineGetter__()
__defineSetter__: __defineSetter__()
__lookupGetter__: __lookupGetter__()
__lookupSetter__: __lookupSetter__()
constructor: Object()
hasOwnProperty: hasOwnProperty()
isPrototypeOf: isPrototypeOf()
propertyIsEnumerable: propertyIsEnumerable()
toLocaleString: toLocaleString()
toString: toString()
valueOf: valueOf()
get __proto__: __proto__()
set __proto__: __proto__()
(anonymous function) @ default.js:6821
(anonymous function) @ default.js:22902
processCallback @ default.js:22386
(anonymous function) @ default.js:22388
callbacks.(anonymous function) @ default.js:22325
Agent._onMessage @ default.js:22318
EventEmitter.emit @ default.js:130
onMessage @ default.js:22283
EventEmitter.emit @ default.js:130
ReliableSocket.onMessage @ default.js:22419
EventEmitter.emit @ default.js:130
ReconnectSocket.onMessage @ default.js:22467
Emitter.emit @ default.js:21897
Socket.onPacket @ default.js:21744
(anonymous function) @ default.js:21722
Emitter.emit @ default.js:21897
Transport.onPacket @ default.js:21778
Transport.onData @ default.js:21778
ws.onmessage @ default.js:21865
default.js:6136 PubSub connected

and

PubSub connected
http://192.168.25.232:3000/static/plugins/c9.ide.layout.classic/loading-flat.css Failed to load resource: the server responded with a status of 404 (Not Found)

#10

I am experiencing exactly the same problem, outline for any language is not working and thus code completion is unavailable too.

I got the bridge plugin from cloud9 github and this last error is not appearing any more, but the message saying “Language worker could not be loaded” is still appearing, outline and code completion not working.

The standalone cloud9 version distributed with the last BeagleBone image (Debian 8.4 2016-05-13 4GB SD LXQT) must be wrong, because I also flashed that one yesterday.
http://beagleboard.org/latest-images

Cloud9: Version 3.1.2374 (08fc5f16f4)
Node: v0.12.13
Chrome: Version 51.0.2704.103 m (64-bit)


#11

In the end my solution was to download, compile an install the latest version of cloud9SDK.

First, all this process was done with a Node.js version 6 and a clean distribution for the BeagleBone Black (BBB).
#Compile the cloud9 application
###Clone the Cloud9 repository (check if this is the last version):

cd /opt
git clone git://github.com/c9/core.git cloud9
cd cloud9
scripts/install-sdk.sh

Make sure all the installation scripts run by this last command run and finish successfully!
###Launch the cloud9 server! Only listen to incoming petitions to 192.168.7.2

node server.js --listen 192.168.7.2 -p 3000 -w /your/project/work/dir -a :

Connect to http://192.168.7.2:3000 to start developing.
###The cloud9 server can be set to be up and running with systemctl as in the original distribution.
You will need to edit:

  • /lib/systemd/system/cloud9.service
  • /lib/systemd/system/cloud9.socket

Performing that configuration can be tricky, as you need to update and fix the connect-architect node module, so perhaps it is just enough for you to connect to the BBB through a SSH connection and then init the process from the console:

systemctl start cloud9.service
systemctl --system daemon-reload

Hope these lines help anyone in the same situation.


#12

Thanks Daniel!

I had the same issue, it works great!


#13

Hi Menno_Faber!
I started right now with Cloud9 in BeagleBone Black. I get the lastest Debian Jessie, version 8.6, available in BeagleBone webpage. Cloud9 is Version 3.1.3088 (14f675858b), nodejs version is 0.12.17 and my problem is the same yours: autocomplete is not working.

Did you get to fix this error?
Thanks


#14

The installation of cloud9 distributed with beaglebone is broken, please report the issue to beaglebone maintainers, or use https://github.com/c9/core


#15

OK!
But, on Beaglebone already have Cloud9 and dependencies installed. Are there some problem if it was installed again like pointed out in https://github.com/c9/core? Or should I take other steps before following this tutorial?

thanks!


#16

Finally I solved the autocomplete code problem in Cloud9. It is necessary to pay attention to the fact that where a previous installation already exists, the old directories must to be removed or renamed before installing the SDK. Then I show below what I did so that the Cloud9 SDK was installed correctly and autocomplete code problem was solved. In root directory, where original Cloud9 was installed, some directories was changed.

NOTE: BeagleBone users with Linux distribution Debian, may consider the same directories indicated below. Other Linux distributions must be observed if the installation locations are the same.

apt-get purge c9-core-installer
cd /root
mkdir bkp
mv .c9/ bkp
mv .node-gyp/ bkp
mv .node-red/ bkp
mv .npm/ bkp
wget -O - https://raw.githubusercontent.com/c9/install/master/install.sh | bash
git clone git://github.com/c9/core.git c9sdk
cd c9sdk/
scripts/install-sdk.sh

Done!

RUN:
To run in background mode, put “&” in the command “node”:
cd /root/c9sdk/
node server.js -l 192.168.137.2 -p 3000 -a :&

NOTES:

  1. After the “wget” command, all processes will take a long time (at least 15 minutes);

  2. I choosen my IP 192.168.137.2 and Port 3000. To open my Cloud9 I type in brower http:// 192.168.137.2:3000/ide.html. But if you don’t like that, so follow standart configuration. Type in you browser http:// localhost:8181/ide.html as shown on https:// github.com/c9/core/