"No application seems to be running here!" error


#1

I started my application which is listening to 0.0.0.0:8080 (host and port from environment variables), pushed “Preview” button and it said: “No application seems to be running here!”. Then I wrote:

$ wget -O - http://0.0.0.0:8080

It worked and successfully printed my page, so I think there may be C9 bug.
I am sorry, there are a lot of topics like this, and I am opening yet another. However, I did not find answer to my question in other topics. Everybody say something like: “I logged off, waited a few hours/days and it is working now!”. I tried to do the same, but it did not worked for me.
I use Ruby, Thin, Sinatra.


#2

maybe it listens on localhost:8080?
try running sudo netstat -tulpn

It should say 0.0.0.0:8080 in Local Address column not 127.0.0.1:8080. Something like:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID
tcp        0      0 127.0.0.1:15454         0.0.0.0:*               LISTEN      -      
tcp        0      0 127.0.0.1:15455         0.0.0.0:*               LISTEN      -      
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      -          

#3

Yes, that is my fault. Thank you. Excuse me for bothering.


#4

How would you change these? I’m having the same issue, and I ran that bash command, seeing the wrong items. Where / how would I change these values?

To be clear, I’ve verified my ENV variables are all set correctly - $IP to 0.0.0.0 & $PORT to 8080. I’ve ran the command to start the Sinatra app every different way (ruby app.rb $IP:$PORT), etc