New user having problem installing MySQL on c9


#1

I’m learning MySQL and I am required to use C9. However, I am having trouble installing it.
I run the command: $ mysql-ctl start
output: command not found.
I tried: mysql-ctl install
output: command not found.
What am I doing wrong? Do I have to install something before using c9? This is a self-study course, so I cannot ask the professor directly. And I dont want to search for another course that doesn’t require c9. I really want to learn this.


#2

Are you taking a Udemy course out of curiosity? I am, and cloud 9 is totally screwed. I cannot successfully run mysql and all my commands started failing after a few days of working. No idea where to go for help.


#4

Got it working like this,
Go to this link, http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/install-LAMP.html.
Scroll down to the section in bold: 'To secure the MySQL server’
Follow all the steps in that section, you are typing into your terminal within your AWS cloud 9 workspace. Once you finish the steps type this in: mysql -u root -p, it will ask you to enter the password you created in the earlier steps. You should now have mysql open.


#5

That works perfectly for me! Mucho Gracias!