New installation for Huginn


can anyone guide me how to install huginn
this is an amazing app but i am unable to install it

please i am requesting you peoples to help me and guide me



Thank you for writing in. From what I can see, the default installation method is using docker, which is currently not supported within Cloud9 hosted workspaces. You can have an SSH workspace connected to a remote machine that allows running docker containers. (Please note that SSH workspaces are a Premium feature).

The other option is to clone the repo and follow instructions for local installation as mentioned on their Readme. Can you try those out and let us know where it runs into issues? We’ll be happy to help.




You already quoted its github readme. Why don’t you go through by yourself?

BTW, here we go:
Create a c9 rails workspace and enter the following command one by one:

git clone git://
cd huginn/
cp .env.example .env
mysql-ctl start
bundle exec rake db:create
bundle exec rake db:migrate
bundle exec rake db:seed <-- cannot donwlad their sample. No idea why

finally, you need to change the port number in the follwing config file:

And kick the app by entering:
bundle exec foreman start

now we see the login page. Good to go


Awesome @556!! :sunglasses:


Thanks bro
can you tell me what port i have to put
sorry for digging your brain


replace 3000 by 8080, 8081, … you name it.
Happy coding :grin:



see i used $PORT but then this error came :sob:

$ bundle exec foreman start
13:56:45 web.1 | started with pid 7656
13:56:45 jobs.1 | started with pid 7657
13:57:40 web.1 | A server is already running. Check /home/ubuntu/workspace/huginn/tmp/pids/
13:57:40 web.1 | => Booting WEBrick
13:57:40 web.1 | => Rails application starting in development on
13:57:40 web.1 | => Run rails server -h for more startup options
13:57:40 web.1 | => Ctrl-C to shutdown server
13:57:40 web.1 | Exiting
13:57:40 web.1 | exited with code 1
13:57:40 system | sending SIGTERM to all processes
13:57:40 jobs.1 | terminated by SIGTERM


Thank you BRO you are love

i just fixed it instead of localhost i used $IP
and then i restart
now its working :heart_eyes:


Wow this application looks very interesting! Thanks for sharing it @isoftmaster :smiley: