New File Line Endings Not Being Applied


#1

I have my new file line endings set to CRLF in the settings, but they are not being applied to any new file I create. Each new file automatically gets set to Unix(LF) in spite of what you see in the image below. Needless to say, it is very frustrating that I have to go back in each new file created and reset the line endings to my preference, and even then it takes several tries of that before I can get my build process to stop throwing errors around this issue. Please fix this. Thank you.

line-endings


#2

how do you create new files? using the plus button or in some other way?


#3

I use the touch command in the command line. I feel that whatever my options are, they should be applied regardless of method of creating new files.


#4

So, that’s it? You’re going to just let it hang like that for the past week without anything to say? Cloud9 IDE can just decide to use different line endings than what I selected as my options, and sometimes it’ll do so in the middle of a build, but I’m going to be left behind without so much as a ‘So long!’? This is extremely poor customer service. This thread has guaranteed that I will be transferring my projects to another platform as soon as I am able.

Thanks for nothing.


#5

Is data being written to these files after the touch through the IDE or through a terminal output? Any terminal writing will be set to the Linux default considering that that is being run entirely though the Ubuntu 14.04 instance backing your workspace; this configuration is for the Ace editor built into the IDE.