MySQL 5.6 installation


#1

Trying to install MySQL 5.6 using sudo apt-get. Everything downloads and installs fine. The previous 5.5 removes. When the service tried to start I get the message:

No directory, logging in with HOME=/
… Failed.

and the service doesn’t start. Any ideas?


#2

Hey @dragonflyysoftware :dragon_face: :smiley:,

There is this C9 Docs page on MySQL here:


I found this Ask Ubuntu page where someone had a similar issue:

Another possible work around is to choose “Wordpress” when creating a new workspace, then just delete all the Wordpress files and update MySQL from there as all the Cloud9 specific things for MySQL will already be in place there.


#3

I checked the first link, it is the instructions for mysql 5.5. Same goes for setting up a wordpress workspace. What I really need is MySQL 5.6. It’s what my home SQL is running on and I’d like to be able to mirror my databases but there are some differences between 5.5 and 5.6. I have tried using apt-get. First tried upgrading and it fails. Then uninstalled the 5.5 server and installed the 5.6. Then I get that error message. I’ve tried setting the owner of the mysql files and it still errors out. Any help would be appreciated.


#4

I found some posts suggesting that the init scripts for mysql-server-5.6 package are broken in Ubuntu. Can you try running the following command instead:

$ sudo service mysql start

See http://sharadchhetri.com/2014/05/07/install-mysql-server-5-6-ubuntu-14-04-lts-trusty-tahr/