My main workspace is locked out

workspace

#1

Hello,

I’ve been using my private workspace (on a free plan) for developing the following website (Just to illustrate that no illegal content or anything): https://codebottle.io/

I’ve been using that workspace for more than a year (I guess), and I’ve never had any issues till now, I opened my workspace and it was in readonly mode:

I realize what the message says, but, I have no idea what caused it? I didn’t change anything around my workspace allocations.

I tried to convert the workspace to a public one, and I was able to access it without issues, however, My website is NOT open-source (so I made it private again, it got locked, as well)

I also tried downgrading my workspace’s RAM from 1GB to 512MB (in case that was the problem), but, I wasn’t able to do so because I am not premium.

I really have no idea what should I do now, setting up a development environment outside Cloud9 is a very, very huge mess for me, and premium is not either an option (for now).


#2

Hi, if your cloud9 username is same as here, you have two private workspaces instead of one, not sure how it allowed you to make both of them private (did you have premium subscription before?).
Try making one of them public.


#3

Oh, thank you @harutyn, I just realized that I have two private workspaces.

No, I was always on a free account. I think this might even be a bug in Cloud9, the trick is that I clicked over the share button on my public workspace, and simply unticked the three checkboxes, and the workspace became private, this has been working for quite several days, until that day where it stopped.

I really didn’t know I was using more than my quota or anything, I thought that workspace was still considered public or something even though I unticked those checkboxes.

Anyways I’m glad things worked for me and a bugfix (in case that was a bug) has been submitted :slight_smile: