Mongod Wont start. Filespace?


#1

My Mongod server wont start unless i use//

mongod --dbpath /data/db --smallfiles

However even if i copy paste this everytime it seems laborious and also will i eventually just run out of space anyway…
Im not sure what files are safe to delete, except my old projects…

Below is the mongod error code:

mongod --help for help and startup options
2017-03-08T23:10:02.947+0000 [initandlisten] MongoDB starting : pid=2137 port=27017 dbpath=/data/db 64-bit host=clayton901-webdevlearning-4472363
2017-03-08T23:10:02.947+0000 [initandlisten] db version v2.6.12
2017-03-08T23:10:02.947+0000 [initandlisten] git version: d73c92b1c85703828b55c2916a5dd4ad46535f6a
2017-03-08T23:10:02.947+0000 [initandlisten] build info: Linux build5.ny.cbi.10gen.cc 2.6.32-431.3.1.el6.x86_64 #1 SMP Fri Jan 3 21:39:27 UTC 2014 x86_64 BOOST_LIB_VERSION=1_49
2017-03-08T23:10:02.947+0000 [initandlisten] allocator: tcmalloc
2017-03-08T23:10:02.947+0000 [initandlisten] options: {}
2017-03-08T23:10:02.960+0000 [initandlisten] journal dir=/data/db/journal
2017-03-08T23:10:02.961+0000 [initandlisten] recover : no journal files present, no recovery needed
2017-03-08T23:10:02.961+0000 [initandlisten]
2017-03-08T23:10:02.961+0000 [initandlisten] ERROR: Insufficient free space for journal files
2017-03-08T23:10:02.961+0000 [initandlisten] Please make at least 3379MB available in /data/db/journal or use --smallfiles
2017-03-08T23:10:02.961+0000 [initandlisten]
2017-03-08T23:10:02.976+0000 [initandlisten] exception in initAndListen: 15926 Insufficient free space for journals, terminating
2017-03-08T23:10:02.976+0000 [initandlisten] dbexit:
2017-03-08T23:10:02.976+0000 [initandlisten] shutdown: going to close listening sockets…
2017-03-08T23:10:02.976+0000 [initandlisten] shutdown: going to flush diaglog…
2017-03-08T23:10:02.976+0000 [initandlisten] shutdown: going to close sockets…
2017-03-08T23:10:02.976+0000 [initandlisten] shutdown: waiting for fs preallocator…
2017-03-08T23:10:02.976+0000 [initandlisten] shutdown: lock for final commit…
2017-03-08T23:10:02.976+0000 [initandlisten] shutdown: final commit…
2017-03-08T23:10:02.976+0000 [initandlisten] shutdown: closing all files…
2017-03-08T23:10:02.976+0000 [initandlisten] closeAllFiles() finished
2017-03-08T23:10:02.976+0000 [initandlisten] journalCleanup…
2017-03-08T23:10:02.976+0000 [initandlisten] removeJournalFiles
2017-03-08T23:10:02.976+0000 [initandlisten] shutdown: removing fs lock…
2017-03-08T23:10:02.977+0000 [initandlisten] dbexit: really exiting now

Any fix?

PS
My other problem, Since Ive had this error is my mongo db is not recognisising the installed EJS i have on it and so is not loading my ejs sites. Some say this is because there is another mongo instance running but i have tried killall commands and cant find any other running db.
Thankyou
Chris


#2

Same problem here. Couldn’t find any solutions yet.


#3

I’ve had the same problem.
The installing tutorial at https://community.c9.io/t/setting-up-mongodb/1717 tells us to use the following command:

echo ‘mongod --bind_ip=$IP --dbpath=data --nojournal --rest “$@”’ > mongod

Just adding the option “–smallfiles” to this command allows mongod to use less memory.

The “dbpath=” option is the database’s folder, if you configure this to your folder correctly it should start without having to type it every time you start the database

echo ‘mongod --bind_ip=$IP --dbpath=data --nojournal --rest --smallfiles “$@”’ > mongod