Missing Semicolon


#1

I have created a .eslintrc file containing the following:

{
	"env": {
		"node": true,
		"jasmine": true
	},
	"rules": {
		"indent": [2, "tab"],
		"quotes": [2, "single"],
		"semi": [2, "never"]
	}
}

Its applying all the rules but I still get the info messages ‘missing semicolon’ even though I though this was disabled in the project settings’

"language": {
        "@warnLevel": "info",
        "@instanceHighlight": true,
        "@undeclaredVars": true,
        "@eslintrc": true,
        "@semi": false,
        "@unusedFunctionArgs": false
    }

Does anyone know why the messages still appear?


#2

Hi @marktyers :slightly_smiling:,

Pardon the late reply. I’m clueless myself on this one but if it’s still an issue, don’t be shy to @mention the C9 Support guys. :wink:

There’s no way to @mention a @group like there is in Slack here in Discourse is there? @admins, poof :star2: (found it!)

Best,
Mike
:alien:


#3

Hi,
there was a bug in handling of semi setting, which should be fixed now, please let us know if you still see any issues with it.
Thanks,
Harutyun