Migrating premium workspace to ensure optimal performance


#1

It seems that on a relatively-regular bassis, I get the message

What's going on here?

We're migrating your premium workspace to a new server 
to ensure optimal performance.

Please wait a moment while we move your workspace. It will
be just as you left it  

Am I misunderstanding this message? It seems to display when a workspace comes out of hibernation rather than a performance migration… My reasoning being; why does the workspace need to be taken out of hibernation in order to trigger the migration? Shouldn’t it be seamless and/or silent?

If this is some sort of performance migration, what would be helpful would be to have some sort of flag that allows us to mark a workspace for “protection” against this migration (when practicable of course). From my experience, it always seems to happen at the most unfortunate time and it’s not a “moment” but sometimes half an hour or more…

This leads to me to further think that possibly this message is either badly-worded or shouldn’t be appearing because in actual fact what’s happening is my workspace is being moved from a hibernation server to a “live” server?

Can support please elaborate a little about what is actually happening here as depending on what’s actually happening, I think possibly there could be some User Experience and/or Quality of Life improvements that could be discussed?

As always, love the service, it’s made a huge difference to my workflow.


#2

I see this very often too.
Not quite convenient.


#3

I think that this thread is entirely relevant to my original post above.

Unfortunately, that thread has been both closed and unlisted by @bradydowling. I understand that the original post was created during some minor downtime hence being closed but actually that thread ended up having a good discussion and could help people who are seeing the problem…

The fact that @dwaynemac has posted in this thread 7 months later should be testament to the fact that my suggestion should probably be considered? @mutahhir seemed to think so, at least?


#4

One of my workspaces is stuck in migration purgatory for the last 8 days! Typically,I can’t see anything wrong on the cloud 9 status page and tweets went unanswered. From the status page, everything looks good, but not sure if this is happening to anyone else.


#5

This isn’t really a solution, but have you tried cloning the workspace? Might be worth a try. Also, have you tried raising a support request from within the IDE? Obviously not from this workspace (!) but from another? (From the IDE: Support->Get Premium Support)


#6

Thanks, I have given up hope and created a new workspace with some project files from my git repo, minus the latest changes. Damn it. Thanks for your reply, though. That’s kind of what I have ended up doing. A little disappointed, as I was close to considering moving all my dev and teaching work here to become a full paying customer (currently on the free + edu plan). Thank dog for git!


#7

That’s a shame - in all honesty, I am a very happy customer and the support I have received via the support system has been top notch. This sounds like hyperbole but it has honestly changed my entire job. I am a full-time web developer and my application of c9 has saved me countless hours.


#8

One of my students is experiencing this issue again and just lost ALL of her work for a project she has been spending hours on because she can not get into her work space. She even left her account up for hours trying to let it load and it is doing nothing. She did not try to upgrade to premium and can get into her other workspaces, but not the one with her project in it.

Is there an actual solution to this problem?


#9

I have the same problem for one of my students. Can we get some help please?

-Steve


#10

All is not lost. When the workspace comes back, it will be just as you left it. If it seems to be stuck in this state, reach out to us at support@c9.io. We’re monitoring this and working on improving this process.


#11

Having the very same issue with one of my workspaces now. Just wrote to support and hope it gets resolved soon.


#12

A tip by @dyrg mentioned in this thread does not work. Cloning a workspace while it is being archived results in an error:

Any chance @bradydowling could have a look please? I’m would be losing hours of work (let alone my inability to work today).


#13

Hope you are right.

Happens to Premium Customer too.

I have lost my files a week ago.

We just tried a restoration point and it didn’t work.

Since the day I asked for help, there has been 27 restorations within a week!

It’s a mystery why there are so many.

What could have triggered them considering I have stayed away from that workspace?


#14

Did you recover your files?


#15

Yes, I did. The workspace was restored promptly the same day (emailed support). I urgently suggest to Git push all changes at least at the end of the day. That was the lesson learned for me.


#16

Good to know. Seem to have lost my files. 24 hours has passed since I asked Customer Support and team which restoration point they had used. Still no reply. Sigh…