Meteor workspace type not listed when I create a new workspace

meteor

#1

I have just created a free account. Trying to create a new workspace, I don’t see Meteor as an available template. Tried some searches on the web and in the community, but I was’n able to find anything relevant.


[solved] Mongod: command not found
Meteor Workspaces should come back!
#2

I have exactly the same problem


#3

same here, and I’ve been using c9 for years


#4

Same problem. Yesterday it was OK.


#5

Same here. Not sure why its like that. Wish they would fix it.


#6

Sorry we’ve removed Meteor as a default workspace type due to a licensing issue. Unfortunately we’re not able to automatically install MongoDB in workspaces as it is against the terms of their license. As Meteor depends on MongoDB and having Meteor without it would probably confuse a lot of users we’ve decided to remove the workspace type.

You can still use Meteor on Cloud9. I’d recommend creating a NodeJS workspace and using something such as http://meteoris.me/ to set it up. Or if you know of a better alternative to Meteoris please let us know here for the benefit of the community.

Regards, Tim


Getting Started with Meteor
#7

If anyone would be interested in writing a simple Meteor getting started tutorial for Cloud9 to go into the #how-to section then PM me :wink: (it’d basically just be a normal hello world tutorial for Meteor but ensuring that they use process.env.IP and process.env.PORT).


#8

Is that against Mongo license or against Meteor license?


#9

Mongo license. @bradydowling would be nice to see a report on guide to making meteor work here.


#10

@Zhan_Karibzhanov indeed it’s Mongo, thank you.

And this guide isn’t a high priority right now but this should provide you more than enough information to make it work:


#11

Where does one go about printing this


#12

Are there any plans of reintegrating a Meteor workspace in the future?


#13

All the info you’re looking for is in this thread :wink:


#14

Well that is a shame, not sure Cloud9 is of any use to me if you no longer support meteor. I tried to create a default workspace and install meteor over the top, but it’s maxing out. That’s a shame, stupid decision if you ask me, but hey, I guess you have your own reasons whatever they may be.


#15

What’s maxing out?

We would love to have a meteor workspace again but unfortunately it’s not up to us. MongoDB chose to disallow automatic installs in their license and we can’t do anything about that. Please contact them if you’d like them to change this policy.


#16

Hey my brothers, i can install meteor simply following the steps from their website…
In console/terminal of a new nodejs workspace:
curl https://install.meteor.com/ | sh
only…
Thanks guys


#17

Yep, Meteor is still installable on C9 but in somehow I am facing with some errors while running an app as documented at http://t.co/uPHXwG9feb

Thanks a lot in advance for any attempt to help.


#18

I’m running into issues with meteor on C9 as well. I haven’t been able to run my app for over two weeks, basically killing my dev. I tried everything I could think of, and rebuilt the workspace multiple times. This morning I cleared out everything, built the “hello world” app with a fresh meteor install and all I get is “Starting your app…” for several hours until C9 kills it. I can build it in the terminal, but it doesn’t set the port and everything like the Run function. At this point I would caution anyone against building with meteor on C9.


#19

Please have a look at Getting Started with Meteor. As mentioned above, It’s basically just be a normal hello world tutorial for Meteor but ensuring that they use process.env.IP and process.env.PORT.


#20

Hi Brady, did you end up writting this how to section? I think I need help configuring the IP and PORT with meteor as it just runs on the local host.