Markdown Relative Links

preview

#1

On github, relative image linking, and relative file linking works just fine in markdown. I even copied code that was directly used on github, that worked on github in c9, and it did not work.

So is relative linking not working in markdown yet or what?


#2

Does absolute linking to other pages in the workspace work? And could you post some of the markdown you’re using here?


#3

Linking to other files does not work, like with this code

## HTML Table of Contents

1. [HTML Intro](/Class%20Materials/CST221/HTML5/HTML-Intro.md)
2. [HTML Page Layout](HTML-PageLayout.md)
3. [HTML Text Formatting](HTML-Text-Formatting.md)

Number 2 and 3 inside the previewer give me this error

AccessDeniedAccess Denied6D95D9FE2B5915C2M+z/ofTTqzMe1tPafrU4fcFwoow3K2edECLGU2SFP8kgTJTYCqvHnLdHNs76IG8965klu0pBEA4=

But if I use an anchor tag inside a file it works, like this code.

## Table of Contents
1. [Signup](#signup)
2. [Create a Workspace](#workspace)
3. [Share your Workspace](#share)
3. [Accessing Classmate's Workspace](#classmate)
4. [Creating Folders](#folders)
5. [Adding a File](#adding)
6. [Running your Files](#running)
7. [Adding C9 Link to Google Doc Spreadsheet](#link)

Update
I just tried absolute links, like with this code, it does not work either.

1. [HTML Intro](https://ide.c9.io/jahenderson/csumb_admin/Class%20Materials/CST221/HTML5/HTML-Intro.md)

error: Cannot GET /jahenderson/csumb_admin/Class%20Materials/CST221/HTML5/HTML-Intro.md


#4

Interesting, I just tried and got the same thing. Looks like the static file previewer isn’t meant to handle markdown links like this.

If you pop out the markdown preview into a new window, you can see that the URL is actually accessing this markdown preview plugin.

If you’re interested, you could see how that preview plugin handles links. Otherwise you could just run a server on your workspace that serves markdown and handles linking on its own.


#5

Yea, I checked out that plugin. Why would the previewer using that plugin, and not managed by my c9 workspace?

I’m kind of getting out my knowledge zone, so I am sorry if what I asked is not correct syntax.

In addition, why are you not be able to run markdown files, and get a link to the file to access in a browser? Why do you have to use the previewer?


#6

Hi @bradydowling

Do you know if there is any update on this issue?

Markdown previews using the c9 plugin still do not work in the same exact way @subtopic detailed out.


#7

There are no updates. I think this will be chalked up as a known limitation of previewing markdown files. If you need more advanced preview than this then I’d suggest trying some sort of markdown server like this one.


#8

Thanks @bradydowling for the swift reply, although I hoped there was a plan to natively get around this limitation. Thanks also for the suggestion.