Listen needs ruby version >= 2.2.3

rails
ruby

#1

Hi. I am getting an error when I run “bundle
update” which says “Gem::Install Error: listen requires Ruby version >= 2.2.3 when I run ruby -v, I find I am running ruby 2.2.1p85.” Can I update ruby? If so, how do I do this - or is there something else I need to do.


#2

Use RVM to change to a specific ruby version:

rvm use <version>

If RVM doesn’t have the version you need, use RVM to install it and then use it just like above:

RVM install <version>


#3

Thanks very much for your help


#4

Hi,

I tried to follow your advice, but as a result I don’t have a “bundle” command any more. What I am doing wrong?
Log below:

~/workspace/sample_app $ rvm reinstall ruby-2.2.3
ruby-2.2.3 - #removing rubies/ruby-2.2.3…
Searching for binary rubies, this might take some time.
Found remote file https://rubies.travis-ci.org/ubuntu/14.04/x86_64/ruby-2.2.3.tar.bz2
Checking requirements for ubuntu.
Requirements installation successful.
ruby-2.2.3 - #configure
ruby-2.2.3 - #download
ruby-2.2.3 - #validate archive
ruby-2.2.3 - #extract
ruby-2.2.3 - #validate binary
ruby-2.2.3 - #setup
ruby-2.2.3 - #gemset created /usr/local/rvm/gems/ruby-2.2.3@global
ruby-2.2.3 - #importing gemset /usr/local/rvm/gemsets/global.gems…
ruby-2.2.3 - #generating global wrappers…
ruby-2.2.3 - #gemset created /usr/local/rvm/gems/ruby-2.2.3
ruby-2.2.3 - #importing gemsetfile /usr/local/rvm/gemsets/default.gems evaluated to empty gem list
ruby-2.2.3 - #generating default wrappers…
Making gemset ruby-2.2.3 pristine…
Making gemset ruby-2.2.3@global pristine…

~/workspace/sample_app $ rvm use 2.2.3
Using /usr/local/rvm/gems/ruby-2.2.3

~/workspace/sample_app $ bundle
bash: bundle: command not found

~/workspace/sample_app $ ls /usr/local/rvm/gems/ruby-2.2.3@global/bin/
executable-hooks-uninstaller* ruby_executable_hooks*

~/workspace/sample_app $ ls /usr/local/rvm/gems/ruby-2.2.1@global/bin/
bundle* bundler* executable-hooks-uninstaller* ruby_executable_hooks*


#5

Answering to my own question:

gem install bundler

will install add bundler tas (at least in some cases) bundler need to be installed separately.

bundler install

would give the rest of the commands (like rake)


#6

Thanks this helped me.