Lftp no longer connects

ftp

#1

I use lftp to transfer files from my C9 IDE to a remote host. In the last week or so, it seems to have stopped working. I’ve raised this with the host, and they think it’s working OK. Indeed, I can connect to the ftp host via FileZilla, and via a simple browser.

I’m transferring a file using the following from the command line:

lftp -e "set ssl:verify-certificate no; put ./res/test.txt -o test.txt ; bye" -u abcd,xyz ftp.example.com

(the set ssl:verify-certificate no was an addition from a while ago, to overcome a similar connection problem that suddenly appeared… I’ve tried without it too)

What I’m finding in C9 is that is forever trying connect, with:

[Connecting...]

Any idea why I’m no longer able to connect?

Thanks.


#2

Anyone? Please? It seems difficult to get any answers at all on this issue.


#3

Does anyone from Cloud 9 browse these forums? I’ve still having this issue.


#4

Hi,

I use this command
set ftp:ssl-allow no;


#5

Hi

Thanks for the suggestion. But still no luck. Just get the same:

[Connecting...]

#6

It may be some security issue because I can load the ftp site concerned in some browsers (e.g. on my phone, at home) but not others (at work). So when connecting from Cloud9, that security issue is possibly kicking in. Not sure how to overcome it though, because in the past it has worked within Cloud9, and every now and then it suddenly starts working, then later it suddenly stops working.


#7

Maybe country blocking of our ftp?
I needed allow United states to my ftp.


#8

Now, yet again, rather strangely and unpredictably, it has started working again, without me having done anything.


#9

And having worked nicely for months, today for no reason it decides to stop working again, with [Connecting...] forever. I can connect to the ftp server just fine in a browser on my phone… just not through Cloud 9… so I know the ftp server is working.

Please can someone from Cloud 9 help?


#10

I am running into the same problem with the connect hanging.

lftp ftp-webresume-user@192.168.0.17:~> ls
`ls’ at 0 [Connecting…]

I suspect the issue is from the Cloud 9 server blocking the ability to connect. Maybe the beginning of the Amazon attempt to shutdown alternative file transfer options and replace them with add on charges to their cloud customers.