Latex for cloud9.io?


#1

Me makefile not work!

all:
	latex memtfg.tex
	latex memtfg.tex
	bibtex memtfg
	latex memtfg.tex
	latex memtfg.tex
	dvips -o memtfg.ps memtfg.dvi
	ps2pdf -sPAPERSIZE=a4 -DMaxSubsetPct=100 -dCompatibilityLevel=1.2 -dSubsetFonts=true -dEmbedAllFonts=true memtfg.ps memtfg.pdf

clean:
	rm -f *.toc *.ps *.log *.lof *.lot *.dvi *.aux *.blg *.bbl

#2

is latex installed on your workspace? use sudo apt-get install if it isn’t


#3

Hi @gcpmendez @harutyun did you get Latex installed in your workspace? I’m having problems with the following command in a blank workspace that I’m setting up for a nodejs Latex project:

sudo apt-get install texlive

The feedback in the terminal is as follows:

mattlindsay:~/workspace/app $ sudo apt-get install texlive
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package texlive

If you can help me get Latex installed that would be greatly appreciated, thanks.


#4

run sudo apt-get update before installing


#5

Thanks @harutyun that got me up and running!