Language worker not working


#1

I’m having an issue in Linux 16.04 64 bits in Chrome Version 52.0.2743.116 (64-bit)
Language worker is not working and I have no autocompletion or any code intelisense.
I’ve opened an issue in the repo
I’m not installing c9 anywhere, just using the online service.


#2

#3

does this happen with sdk or c9.io?


#4

It happens in c9.io after a few seconds when the page is loaded. A red toast appears on top telling me that.


#5

Please tell the url of the workspace where this is happening, is it ssh or hosted workspace?


#6

It’s a ssh workspace
https://ide.c9.io/quantilope/namir_sayed_ahmad_baraza


#7

most likely this means there was an error while installing sqlite3.
Try running the manual installer from https://github.com/c9/install, closing and opening the ide in a new tab.
You can also connect to support, if you want someone from support to do that.


#8

I’ve tried reinstalling it but nothing happens.
And it works for me using firefox. So it seems to be browser related


#9

Are there any errors in the browser console, and do you see the same warning with other projects?


#10

It happens in every workspace, even in a hosted one.

These errrors appears. If you want more detail in any of those, please tell me :smile:


#11

Seeing the full image, or copy of full text in the console would help. The last error in the image is interesting, are there more errors after it?
Btw is this your workspace or you are a collaborator?


#12

All the errors

I’m not the owner, it’s a shared workspace. But this is only happening to me in the environment as I said. Other collaborators can enter and have no problems with it. So it doesn’t seem to be workspace related but browser/OS related IMO.

Edit

and remember it happens in every workspace, not only in this one
Thanks!


#13

Any news? I miss using chrome and c9 together :frowning:


#14

Sorry no progress yet, and i do not see yet what could cause this to happen, but we got one more similar report Language worker could not be loaded;

Could you try opening the ide in a private tab, to make sure it’s not an issue with cache or extension?


#15

Okey, i’ve tried in a private tab and its working.
I’m going to clear my cache and check extensions.
Thanks alot!