JSLint setting not respected on JSBeautify

javascript

#1

There should be a space between function and () from the "@jslinthappy": true, setting for JSBeautify, but it is not working.


#2

We had a regression on our end yesterday. As we’re preparing to launch new code formatters, and it looks like we might accidentally changed your default. The default should be restored again, but please check whether Preferences > Project > JavaScript Support > Use Built-In JSBeautify as Code Formatter is enabled and post back here if you still have any trouble.


#3

@lennartcl, thanks for the reply. It is set to use JSBeautify, but is still not respecting the JSLint setting.


#4

Hi Ryan, it looks like the JSBeautify plugin was using your user settings, while we have moved these settings to project settings. We’re rolling out a fix that I expect to be fully live on Monday. Thanks for reporting!


#5

Everything is working perfectly now, thank you!