Joomla - can't install extensions

joomla

#1

I’m excited to have installed Joomla into a new workspace but I can’t install any extensions because I get the message “Maximum PHP file upload size is too small”. The solution on all the forums is to modify either the .htaccess file or php.ini file with the command
php_value upload_max_filesize 4M

I’ve tried creating the .htaccess file but that didn’t work and I can’t figure out how to access and edit the php.ini file. Any help is appreciated.


#2

Try setting it in the php.ini in your workspace, that will make it apply site-wide. It should apply the changes when you restart apache


#3

Doesn’t seems to work but perhaps I don’t fully understand your instructions. I created a php.ini file in the parent folder with a single line of code
php_value upload_max_filesize 4M

I then restarted the workspace.
Checking system information/php information in the backend of Joomla it doesn’t reference this new php.ini file and no settings have been changed.


#4

My mistake, it was being reference but then overwritten by .htaccess.