Java Runner not finding application after I build workspace


#1

I’m working on a java application. Long story short, I made another one a while back, built it with the Cloud9 suggested custom builder. It worked. I was able to run the program with the custom-made Java runner. Now I’m making a new project. It’s not complete, but it let me build the workspace. Some files are empty, and some are filled. I made a test main application to see if one of the user functions worked. After building it, and running it, it gives me this error.
Running slayer.java

Error: Could not find or load main class slayerGame.slayer                                                                                                                                                     
                                                                                                                                                                                                               
                                                                                                                                                                                                               
Process exited with code: 123

I tried running one of the class files, user.java; I built it, and this is what I get:

Building workspace                                                                                                                                                                                             
Done!                                                                                                                                                                                                          
                                                                                                                                                                                                               
                                                                                                                                                                                                               
Process exited with code: 0

I run the file.

Running user.java                                                                                                                                                                                              
                                                                                                                                                                                                               
Error: Could not find or load main class slayerGame.assets.user                                                                                                                                                
                                                                                                                                                                                                               
                                                                                                                                                                                                               
Process exited with code: 123

Here is my folder structure.

slayerGame
    assets
        functions.java
        user.java
        monsters.java
        levels.java
        items.java
        quests.java
    slayer.java

Here’s the slayer.java file.

package slayerGame;

import assets.functions.*;
import assets.items.*;
import assets.levels.*;
import assets.monsters.*;
import assets.quests.*;
import assets.user.*;
import java.lang.*;
import java.util.*;

public class slayer {
    
    public static void main(String[] args) {
        System.out.println(assets.user.postLvl());
    }
}

#2

Have you been able to solve this on your own? I’m having a simmilar problem where, if I run a helloworld class with no imports from my current project, it works fine. As soon as I use any libs from my project, it goes bad.