Japanese input for terminal is broken


#1

For reference: Here is Windows 7 cmd prompt with Japanese input.

Here is cloud 9 terminal:

It seems like after every key press, the terminal is grabbing the queued Japanese text (before confirming with Enter) and inputting it.

In both examples I typed “asasasasa” which should create one “a” symbol あ and repeated “sa” symbols さ… This is the behavior in cmd.

I think one way to solve this is similar to codeanywhere:

Notice how when I move the cursor to the terminal, the Japanese IME switcher indents all the buttons, which means I am forced into typing English and can not switch to Japanese.

This is fine for most Japanese, as terminal cmds rarely use Japanese, and we usually name source files in English to prevent compile errors and encoding errors on different systems.

It’s kind of annoying that when I am typing a Japanese comment on some source file and I switch over to terminal and forget to switch to english, I have to take a few seconds deleting the long string of nonsense Japanese, then switch back to English and retype it.


Korean(2Byte Character) typing Issue in C9 IDE
#2

Maybe this will help understanding of how it works.


#3

Thanks for the bug report, we have released a fix for terminal grabbing ime input in the middle of composition.
disabling ime in the terminal is possible too, do you prefer that to having working ime in the terminal?


#4

oh! Thanks so much! :smiley: This will make things more productive.

I think that it would be better to have a toggle in User Settings > Editors > Terminal with a toggle called “Allow non-ASCII input through IME” default to ON but can turn OFF. (ON would be like function in c9 right now, and OFF would be like ca where the IME is disabled when the cursor is on the temrinal)

Thanks again.