Isogenice Game Engine on c9.io?

nodejs

#1

Hello. Can you explain me how to run multiplayer example project of isogenic game engine on c9.io?
I have installed this engine and then I do this:

node ./server/ige -g ./examples/24.1-network-stream

and then it happens

IGE log [IgeNetIoComponent] : Network component initiated with Net.IO version: 1.0.0
IGE log [IgeNetIoComponent] : Starting net.io listener on port 8080
IGE log [IgeNetIoComponent] : Starting client/server clock sync…
IGE log [NetIo.Server] : Server is listening on port 8080
IGE log [IgeEngine:ige] : Starting engine…
IGE log [IgeEngine:ige] : Engine started
IGE log [IgeStreamComponent] : Setting delta stream interval to 30ms
IGE log [IgeStreamComponent] : Starting delta stream…
IGE log [IgeNetIoComponent] : Server now accepting connections!

then I’m going to example project folder and run index.html file (or server.js) and it show this:

Started apache2
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:8080
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:8080
no listening sockets available, shutting down
AH00015: Unable to open logs

So what I’m doing wrong?

(sorry for mistakes. english is not my native language)


#2

Hmm. Try restarting apache, or see if another process is using port 8080.

To restart apache run this comand in your terminal:
sudo service apache2 restart

And to list the processes that are using a specific port try this:
sudo netstat -lnp | grep 8080


#3

@vasilenko93

Isogenic Engine will not serve static game files from the Node.js server, it only serves to handle incomming socket connections for multiplayer / streaming functionality.

You must serve your game files from a separate HTTP server such as apache.

it’s from manual
Apache stopped working by itself.
Should I change apache port or smth? and how?


#4

It is strange that both the server and client are using the same port. I am on my phone right now, so maybe in an hour I can get on a computer and investigate.


#5

Okay so apparently by default on cloud9 the apache virtual host config for a site is port 8080. So try changing it to port 80. You have to modify this file:
/etc/apache2/sites-enabled/001-cloud9.conf
With some kind of terminal text editor, and change
<VirtualHost *:8080>
to
<VirtualHost *:80>

And I believe a restart of Apache will be required too.