Is copy/past option available or this is bug that prohibited copy and past?


#1

When Ive tried to copy and pass on Cloud9 my formatting all mix up no matter what I did.
I’ve tried to use unformatted test, make more space between items before I past them, but
the formatting is completely mix up(part on example below)

* miscellaneous */ .debug_dump  -//
//should be two different lines but below is just one line.....

Please help me correctly copy and past or inform me that this option is not available on Cloud 9 or this kind of sort of bug that need to be fixed.
thanks.

/* miscellaneous */ .debug_dump {
  clear: both;
  float: left;
  width: 100%;
  margin-top: 45px;
  @include box_sizing;
}
/* universal */ body {
  padding-top: 60px;
}

#2

Hi, could you tell us more about the issue.

  • on which workspace did this happen?
  • are you copying the text from code editor, from terminal, from another application?
  • do you paste it to code editor?
  • do you copy paste with keyboard or context menu?
  • which browser operating system did you use?

#3

my workspace is ~tatyana_pol:~/workspace/sample_app (sign-up)-branch
I am copied from :


Listing 7.5, listing 7.11 and so on I’ve tried to follow instruction and got
complete app/assets/stylesheets/custom.css.scss
I passed directly to the terminal but it is mix up. I’ve tried paste directly, use cmd V, make
more space - still errors pasting…
I am on Mac. Using Safary.
What should I do to get clean custom.css.scss file without copy/past errors?
thanks.


#4

this looks like a bug in nano editor, to edit files it’s better to use cloud9 builtin editor instead of nano


#5

where builtin editor is located? Could I use it?
thanks.


#6

Please disregard the previous message: I figured it out.
So far no problem using c9 editor.
thanks.


#7

Hi. Whenever I copy something from the terminal or text editor, whatever I paste ends up as tofu (the rectangle that appears in place of unsupported characters). Is there a way to work around this? I’m using Google Chrome. I don’t know if I’m using the nano editor or not, but that still would prevent me from copying things from the terminal, I’m guessing.

I added some CSS to my stylesheet to make sure that comments are italicized, but I doubt that it’s the root of the issue.


#8

Try in incognito mode, or disable all extensions.
Some chrome extensions (e.g. https://chrome.google.com/webstore/detail/dont-fuck-with-paste/nkgllhigpcljnhoakjkgaieabnkmgdkb?hl=en) are known to break clipboard on cloud9


#9

Oh, that’s probably it. Thank you!