INVALID_SESSION_ID when trying to sync new Salesforce workspace

salesforce

#1

Hi,

I just tried to create a new Salesforce workspace from this org URL (which is a bit typical URL since it is a sandbox actually…working for Salesforce sometimes makes life challenging): https://isvte–tr.cs17.my.salesforce.com/

Although I am able to authorize c9 for the org using OAuth, it doesn’t sync. I get an INVALID_SESSION_ID.


#2

Do you have any IP restrictions configured? We saw this error message with orgs that have Lock sessions to the IP address from which they originated enabled in the settings.

Our platform is set up so that the IDE and authentication services are running on different machines with different outbound IP addresses. As a workaround, turning that setting off works.


#3

Thanks. That was on indeed. Will recheck.


#4

Works like a charm. Thanks for the fast reply!