Interface corrupted in workspace


#1

For about the last 30 minutes, when I log in, the window that is displayed is totally corrupted. Using Firefox. Tried with Windows IE 10, same result. Is there an outage? Was there a code change to the interface that corrupted it? Screen shot follows:


#2

There doesn’t appear to be any outages anywhere. It looks from here as though the static assets aren’t loading though.

Are you able to press F12 to open the developer console, click the console button and re-open the page and attach a screenshot of the errors you’re seeing there?


#3

yes. see below.


#4

I am also having an issue with the interface.

any solutions?


#5

Also having interface issues.

There look to be some issues loading a few things.

Three GET failures:


#6

It’s happening for me and a coworker as well. We’re using the dark theme and one of the 503’s we see is for dark.css. Is everyone here using dark.css?


#7

@fidian Is the dark theme the default? I’ve never changed mine. Where would I check?


#8

Negative, it is a setting that you need to change. I believe it’s under User Settings, though I can’t say for certain because the UI is all messed up for me. Good to know that this isn’t related to a single theme.


#9

This only happens for me when trying to use a recently active workspace. Another one of my workspaces that was not recently active loads up fine.


#10

The problem seems to have resolved overnight, at least for me. Has it resolved yet for anyone else? I see that many of the comments are within the last couple hours.

I don’t know if something happened via automation or if someone has manually intervened. Because there have been so many others with this problem, and because I want to see that it doesn’t happen again in the near future, I will leave this open for now.

I would also like to see a response from cloud9 staff on this matter about the cause and resolution.


#11

I am still having the problem. I have some pair work to do today but I’ll have to rig something else up instead. If you check status.c9.io you’ll see that they claimed to have a problem with something, but shortly after said they fixed it.

Clearly it’s still broken for some of us.


#12

I’m having the same problem, and am using the dark theme. I’m glad I’m not the only one, as I thought I might have fat-fingered a keyboard command that disabled styles… O_o


#13

The problem seems to be theme related for me. Adding ?reset=1 to the end of the url resets the theme (and some other settings) and fixes the problem. For me the problem occurs when I try using the Cloud 9 Classic Dark Theme as my main theme. I’d recommend trying either the Classic Dark Low Color theme or the Flat Day Theme if the issue is truly with the Classic Dark Theme, at least until there is an official response.


#14

Thanks for the reports on this. Can others having this issue check if:

  1. Those same console errors show up
  2. Changing the theme fixes it (if you can even get to this with the issue)
  3. Adding ?reset=1 to the URL fixes it

#15

Adding ?reset= did not fix it for me. No observable changes.

Adding ?reset=1 fixed the theme issue and now I can see things again. When will the dark theme get fixed?


#16

?reset=1 also worked for me.


#17

Once you have done this, you should be able to see all IDE themes. The new flat dark theme is a WIP and I’m not sure when it will be fully functional.


#18

“The new flat dark theme is a WIP and … not fully functional” does not explain why the theme I’ve been using since I became a Cloud9 user stopped working all of a sudden, nor does it fully explain XMLHttpRequest / service failures and a lack of transparent status…

When will the “old dark theme” be working again … ?


#19

Can you try clearing your cache and loading that theme again?


#20

Doing that just seemed to hose both the light theme…