Installing KeystoneJS on Cloud9

keystonejs
javascript

#1

I have tried a few times to install http://keystonejs.com/getting-started/. It has not worked at all…
Not sure why.

This is what happens:

npm@3.5.1 /home/ubuntu/.nvm/versions/node/v4.1.1/lib/node_modules/npm
brodriguez_jtap:~/workspace/www $ sudo npm install generator-keystone
npm WARN deprecated CSSselect@0.4.1: the module is now available as 'css-select'
npm WARN deprecated CSSwhat@0.4.7: the module is now available as 'css-what'
extract                   ▀ ╢████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░╟

And it does not finish… then…
I run yo keystone and go through the prompt and it says:

------------------------------------------------

Your KeystoneJS project is ready to go!

For help getting started, visit http://keystonejs.com/guide

To start your new website, run "node keystone".

brodriguez_jtap:~/workspace/www $ node keystone
module.js:338
    throw err;
    ^

Error: Cannot find module 'grappling-hook'
--------------------------------------------------------------------------

Because it did not install all dependent module. Now i have installed 1 by 1 as lists the errors… but i make it to a point where i can install any other anymore and it still doesnt run.

Any insight would be great! Trying to set up a Dev environment for this CMS.


#2

Hi there!

Thank you for writing in. I recorded a quick video to help install KeystoneJS on a Cloud9 workspace:

I hope this helps.

Regards,
​Mutahhir


#4

@mutahhir Hi Mutahhir, could you please help me as well. I have a KeystoneJS app. I have done some steps as you did in the video, so my app is running on 0.0.0.0:8080, but then it is not reachable in the preview. Can you help me please to debug this?

Thanks.

Vitek