Installing apt-transport-https in a blank workspace


#1

Hi there!

Lately, I’ve been trying to run a version of Nadekobot for Discord on a Cloud9 workspace. However, in order to get it running, I have to install apt-transport-https in my workspace. I’m extremely new to all of this, so I have absolutely no idea how I would go about doing that. Could anyone provide me with some help?

EDIT: I’ve tried running this line of code in my workspace:

sudo apt-get -y --no-install-recommends install \
curl \
apt-transport-https \
ca-certificates \
software-properties-common

but when I do, I get this output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package apt-transport-https

I’m trying to get apt-transport-https in my workspace (the only thing I’m trying to do right now), but I haven’t managed to. Any help?

Running sudo apt-get install apt-transport-https also doesn’t work.


#2

Can you first run sudo apt-get update in order to update the package lists, then try installing it?


#3

Inputting the string into the bash returns:

E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?

I’m not sure how to get around this.


#4

I’m pretty sure apt-transport-https comes preinstalled on workspaces. I just created a fresh one to double check :wink:


#5

I tried running this in a prior workspace as well, which also didn’t have apt-transport-https in it. I thought that moving to another workspace and trying again might help with that, since I saw the other thread about this and I saw your reply, but it still didn’t work. I’m not entirely sure what to do from here, especially since I couldn’t execute the other fix detailed in the thread successfully.