In Vivaldi, keybindings run browser commands, not IDE commands


#1

I have started using Vivaldi (really awesome!) and I am having some problems with the keyboard shortcuts. For example, when using the IDE, common shortcuts such as clearing terminal (Ctrl + L), exiting a Python/Ruby console (Ctrl + D), searching with the text editor (Ctrl + F), saving a file (Ctrl + S) all fire up Vivaldi’s pre-configured shortcuts.

I didn’t have this problem with Chrome or Firefox, somehow Cloud 9 (or the browsers) would not trigger their own shortcuts in favor of Cloud 9’s own keyboard shortcuts.

Is there any way to achieve this with Vivaldi?

Thanks.


Supported Browsers
#2

First, really interesting that you’re using Vivaldi, you have piqued my curiosity and I’d like to give it a try.

As for the cause of this, I’m not familiar enough with the commands plugin to know for sure if this is an issue with Cloud9 or Vivaldi but my guess is Vivaldi :grin:

That said, Vivaldi support isn’t currently the highest priority as you could imagine so I’d just suggest taking a gander at the code in the plugin I referenced and see if anything obvious shows itself as the cause of this.


#3

this is an issue in vivaldi, other browsers wait for the page to handle keys first, but vivaldi does not.
As a workaround you can disable some of vivaldi shortcuts from its options page, but unfortunately it disables them for all sites.


#4

I see. I was afraid this was a Vivaldi issue. I hope they fix this soon.

Thanks for the help guys. And @bradydowling let me know what you think of Vivaldi :smiley: