Icecast2 problem with remote connection


#1

Hello,
I’m using cloud9 for testing and development purposes. I installed an IceCast2 server on port 8080 in a PHP & Apache & MySQL workspace.
I raise perfect the service but the want to transmit creating a point of monjate this is never created.
On my local computer, with the same configuration data, the mount point is created perfect. In cloud9 I could not create the mount point.
Is there any port blocked, or should I do some special procedure like port forwarding or something similar?

I do not think the problem comes from the configuration of Icecast2, since it is installed and tested on other servers.

Sorry for my english, I’m using google translate so I can pass on my problem.

My icecast.xml is:

<icecast>
    <limits>
        <clients>5</clients>
        <sources>5</sources>
        <threadpool>5</threadpool>
        <queue-size>524288</queue-size>
        <client-timeout>30</client-timeout>
        <header-timeout>15</header-timeout>
        <source-timeout>10</source-timeout>
        <burst-on-connect>1</burst-on-connect>
        <burst-size>65535</burst-size>
    </limits>

    <authentication>
        <source-password>pepe99</source-password>
        <relay-password>pepe99</relay-password>

        <admin-user>admin</admin-user>
        <admin-password>pepe99</admin-password>
    </authentication>



    <!-- The next several lines will eventually build the URL to be
         used.  The format is as follows:
         
         http://{hostname}:{port}{mount-name}

         hence, if your hostname is chunky.monkey.com and you 
         serve on port 8000 with a mount of "/tunes.mp3" then
         the browser/listening device will use the url

         http://chunky.monkey.com:8000/tunes.mp3

         Note here that the hostname contains NEITHER the http://
         NOR the forward slash on the end.  The http:// is 
         automatic and the forward slash is on the BEGINNING of 
         the mount-name.
-->

    <!-- hostname can be the FQDN, "localhost", "127.0.0.1",
         "192.168.x.y", whatever.  If you can ping it and get
         a response, then it is what goes here. -->
    <hostname>MYWORSPACENAME-username.c9users.io</hostname>

    <listen-socket>
        <port>8080</port>
    </listen-socket>
    

    <!--<mount>

        <mount-name>/stream</mount-name>

        <username>source</username>
        <password>pepe99</password>

        <max-listeners>5</max-listeners>

        <hidden>1</hidden>
        <no-yp>1</no-yp>
    </mount>-->


    <fileserve>1</fileserve>

    <paths>
    <!-- basedir is only used if chroot is enabled -->
        <basedir>/usr/share/icecast2</basedir>

        <!-- Note that if <chroot> is turned on below, these paths must 
             both be relative to the new root, not the original root -->
        <logdir>/var/log/icecast2</logdir>
        <webroot>/usr/share/icecast2/web</webroot>
        <adminroot>/usr/share/icecast2/admin</adminroot>

        <alias source="/" dest="/status.xsl"/>
    </paths>

    <logging>
        <accesslog>access.log</accesslog>
        <errorlog>error.log</errorlog>
        <loglevel>4</loglevel> <!-- 4 Debug, 3 Info, 2 Warn, 1 Error -->
        <logsize>10000</logsize> <!-- Max size of a logfile -->
    </logging>

    <security>
        <chroot>0</chroot>
    </security>
</icecast>

Thank you very much


#2

try using 0.0.0.0 for hostname, or edit /etc/hosts to point MYWORSPACENAME-username.c9users.io to 0.0.0.0, by running

echo "0.0.0.0 $C9_HOSTNAME" | sudo tee -a /etc/hosts

#3

Thank you,

But the problem persist. I need to do something more with the port?

Thanks!