I seem to have broken my CS50 IDE. Any ideas how to fix it?

workspace
cs50
ide

#1

Hey everyone, so I’m using Cloud9 as part of Harvard’s CS50 course on edX for the CS50 IDE.

It seems I’ve broken it though. Here’s a video of how it behaves for me.

Also, I’m getting this issue about my email. It seems that there’s some conflict about edX relaying my email to Cloud9 correctly - or Cloud9 understanding that it already has my email?

Regarding the broken IDE - I also tried Logging Out as well as Restarting the IDE again. Nothing helped though.
I tried in both Chrome and Edge.

Cheers for any and all help.


#2

If nobody here can help me, can someone point me to where I can best get support for this issue?

As it stands I cannot continue with the course.


#3

Sorry for the late reply, i’ve restored your ide just now.
in such cases opening the ide with ?reset=state or ?reset=1 to reset settings can help, but if this happens again, please let us know since broken settings may help to find underlying issue.

Do you remember what you were doing when it broke?


#4

As about the email issue, you have two accounts chrisoffner created with edx and older chrisoffner3d.

Note: user with this email address already exists, generally means that the email you provided is already registered for another user.