I could not upload project to c9


#1

I clone my project from Bitbucket and was trying to upload to c9 but could not do it.
First of all it was said that I need use only Firefox and not Safari. But I could not upload it
in Farfox either… I drag and drop project, tried to upload files but there were no uploading as such and
no any messages…
I think that maybe problem with project name ( I have the same project name already), so I’ve changed the name but still could not upload…
If clone doesn’t work, then how/is it possible to upload directly from Bitbucket?
Could you pleas help me to upload the project to c9?
thanks.


#2

Hi, I understand that you cloned your BitBucket locally (meaning on your laptop), right? Why don’t you create a new workspace/project on c9 and link it directly to your BitBucket repo?

Link: https://docs.c9.io/docs/setting-up-github-workspace


#3

Hi.
Right now I have one private workspace. And it is not work as intentded : I could not use master branch.So, I am
thinking to delete this workspace and start new by coping projects from Bitbucket. My point is: why should i keep this
only one free workspace if it doesn’t work as it is supposed: when I’ve changed branch, it change master - not supposed to be this way.
Is my c9 directory correct as below:

workspace (master)

$ ls -la
total 36
drwxrwxr-x 9 ubuntu ubuntu 4096 Apr 6 23:54 ./
drwxr-xr-x 23 ubuntu ubuntu 4096 Apr 6 23:53 …/
drwxr-xr-x 8 ubuntu ubuntu 4096 Mar 20 05:51 .1.git/
drwxr-xr-x 2 ubuntu ubuntu 4096 Feb 27 08:22 .bundle/
drwxr-xr-x 3 ubuntu ubuntu 4096 Feb 21 07:07 .c9/
drwxr-xr-x 8 ubuntu ubuntu 4096 Mar 20 05:51 .git/
drwxr-xr-x 15 ubuntu ubuntu 4096 Apr 4 00:42 active_app/


#4

I cloned the projects on the different workspace. But for some reasons I could not see
output of one project even so I could see it before. There are no errors messages but out put is just show.
How to fix it?
tatyana_pol:~/workspace/tatyana_app (master) $ rails server -b $IP -p $PORT
=> Booting Puma
=> Rails 4.2.2 application starting in development on http://0.0.0.0:8080
=> Run rails server -h for more startup options
=> Ctrl-C to shutdown server
[5620] Puma starting in cluster mode…
[5620] * Version 3.1.0 (ruby 2.3.0-p0), codename: El Niño Winter Wonderland
[5620] * Min threads: 5, max threads: 5
[5620] * Environment: development
[5620] * Process workers: 2
[5620] * Preloading application
[5620] * Listening on tcp://0.0.0.0:8080
[5620] Use Ctrl-C to stop
[5620] - Worker 1 (pid: 5628) booted, phase: 0