I broke a c9.io workspace!


#1

I think I broke c9.io

https://ide.c9.io/herohamp/clear_test

Nothing will load!


#2

More context needed.


#3

Ok so I ran the command
rm -rf / --no-preserve-root

Then the console got spammed with no permission. After that non commands would work as it would say that it could not find it. then when I rebooted to workspace everything just broke!


#4

Well…should not have entered that command. The workspaces are virtual Linux machines running Ubuntu.


#5

Lol. Why did you run this command? It deletes everything in your project, so nothing is going to work after you do that. You should just delete that project and start again. Did you have anything of importance in the project?


#6

you forgot to add sudo
:grin:


#7

Well, that’s interesting…

That’s one of the thing I did a long time ago when I first tried Cloud9. Because I was able to do it, I immediately fell in love with Cloud9 :heart:.

Ahah, Nostalgy :slight_smile:


#9

:expressionless:

:laughing:


#10

I used sudo nothing changed :stuck_out_tongue:


#11

No I made a new workspace just for trying to break cloud9 xD


#12

Good Job lol. you apparently made it in the news: https://status.c9.io/


#13

xD. That is just amazing! All I did was type
rm -rf / --no-preserve-root
then reboot the system


#14

That incident was completely unrelated. We wouldn’t last very long if any user could take down Cloud9 by deleting their files :stuck_out_tongue:


#15

Its a worksapce… that is a copy, of an original workspace that is posted in github… and each of us have our own Ubuntu “VM” When we create a workspace… So your workspace wont affect mine at all. Which is preety fair!