HTML snippets clobbering Emmet


#1

Hitting “p” and then “tab” results in:

<input type="password" name=""/>

Not in:

<p></p>

This remains true even if I go into my keybindings and try to set snippet tab completion to literally anything else I’ve tried–tab still does it. Changing Emmet’s key binding works, but I don’t see any reason why tab shouldn’t work. Disabling auto-completion in my preferences also has no effect on the snippets, though it does remove the rest of the auto-complete items from the list that pops up. I can’t find any documentation anywhere on how to remove individual snippets or disable them entirely.

I have already tried restarting my workspace after making these changes, to no effect.


Is it possible to disable HTML snippets?
#2

I have the same problem. Also, instead of getting…

<li></li>

I get…

<link rel="stylesheet" href="" type="text/css" />