How to update Ubuntu

ubuntu

#1

I am taking a robotics course on EdX that requires us to have Ubuntu Wily (15.10) or Ubuntu Xenial (16.04 LTS) in order to use ROS (The Robot Operating System).

When I try to follow instructions to install the newer version (using the server version), I get the message

Package update-manager-core is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'update-manager-core' has no installation candidate

How can I upgrade the version of Ubuntu on Cloud9?


#2

Before we’ll proceed, please let us know which Ubuntu version do you use.

You may check this running lsb-release -a command.

Thank you.


#3

Sorry for taking so long to get back to you.

Ubuntu 14.04.3 LTS

It’s the default for creating a new workspace.